Zenway

Linux - это интересно!

Вы не вошли.

#1 08-03-2013 00:35:42

redix
Участник
Откуда: Shangri-La
Здесь с 14-02-2013
Сообщений: 2,398
LinuxChrome 25.0

Не могу обновить Manjaro linux (решено)

[redix@slash ~]$ sudo pacman -Syu
:: Синхронизируются базы данных пакетов...
basis не устарел
platform не устарел
addon не устарел
extra не устарел
community не устарел
basis-multilib не устарел
multilib не устарел
mate не устарел
:: Запускается полное обновление системы...
:: Заменить khrplatform-devel на extra/mesa? [Y/n] y
:: Заменить lib32-libgl на basis-multilib/lib32-mesa-libgl? [Y/n] y
:: Заменить lib32-libglapi на multilib/lib32-mesa? [Y/n] y
:: Заменить lib32-qt на multilib/lib32-qt4? [Y/n] y
:: Заменить libegl на extra/mesa? [Y/n] y
:: Заменить libgbm на extra/mesa? [Y/n] y
:: Заменить libgl на basis/mesa-libgl? [Y/n] y
:: Заменить libglapi на extra/mesa? [Y/n] y
:: Заменить qt на extra/qt4? [Y/n] y
предупреждение: razor-qt: установленная версия (0.5.2-2) новее, чем в addon (0.5.2-1)
разрешение зависимостей...
проверка на взаимную несовместимость...
ошибка: не удалось подготовить запрос (не удалось удовлетворить зависимости)
:: jag: требует qt
:: razor-qt: требует qt
:: ridual: требует qt>=4.6
Ещё  и Pamac пропал из трея. Что можно сделать?


In Tux We Trust

Вне форума

#2 08-03-2013 03:18:37

posixru
Модератор
Откуда: СССР
Здесь с 21-10-2010
Сообщений: 1,448
Сайт
LinuxSeaMonkey 2.16

Re: Не могу обновить Manjaro linux (решено)

Теперь пакет что раньше был qt зовётся qt4 (qt теперь на AUR), можно попробовать:

yaourt -Syua -f

Если не считать почти двухсот метров обновлений, у меня c Manjaro всё прошло нормально...

(91/91) проверяется целостность пакета             [################] 100%
(91/91) загрузка файлов пакета                     [################] 100%
(91/91) проверка возможных конфликтов файлов       [################] 100%
(97/97) проверяется доступное место                [################] 100%
(1/6) удаление khrplatform-devel                   [################] 100%
(2/6) удаление libegl                              [################] 100%
(3/6) удаление libgbm                              [################] 100%
(4/6) удаление libglapi                            [################] 100%
(5/6) удаление libgl                               [################] 100%
xorg configuration symlink valid...
libGl and libglx symlinks are invalid!
Falling back to default...
warning: could not find '/usr/lib/libGL.so.mesa'!
libglx: '/usr/lib/xorg/modules/extensions/libglx.xorg'
(6/6) удаление qt                                  [################] 100%
( 1/91) обновление libpng                          [################] 100%
( 2/91) обновление mesa                            [################] 100%
( 3/91) установка mesa-libgl                       [################] 100%
xorg configuration symlink valid...
libGl and libglx symlinks valid...
( 4/91) установка qt4                              [################] 100%
Дополнительные зависимости для qt4
    postgresql-libs: PostgreSQL driver
    libmysqlclient: MySQL driver
    unixodbc: ODBC driver
    libfbclient: Firebird/iBase driver
    libxinerama: Xinerama support
    libxcursor: Xcursor support
    libxfixes: Xfixes support
    icu: Unicode support
( 5/91) обновление libdbusmenu-qt                  [################] 100%
( 6/91) обновление appmenu-qt                      [################] 100%
( 7/91) обновление arandr                          [################] 100%
( 8/91) обновление automoc4                        [################] 100%
( 9/91) обновление avahi                           [################] 100%
Новые дополнительные зависимости для avahi
    qt4: qt4 bindings
(10/91) обновление ca-certificates-java            [################] 100%
(11/91) обновление cairo                           [################] 100%
(12/91) обновление poppler                         [################] 100%
(13/91) обновление poppler-qt                      [################] 100%
(14/91) обновление qtwebkit                        [################] 100%
(15/91) обновление sip                             [################] 100%
(16/91) обновление python2-sip                     [################] 100%
(17/91) обновление pyqt-common                     [################] 100%
(18/91) обновление python2-pyqt                    [################] 100%
(19/91) обновление calibre                         [################] 100%
(20/91) обновление cmake                           [################] 100%
Новые дополнительные зависимости для cmake
    qt5-base: cmake-gui
(21/91) обновление djview4                         [################] 100%
(22/91) обновление gtk-update-icon-cache           [################] 100%
(23/91) установка libxkbcommon                     [################] 100%
(24/91) обновление gtk3                            [################] 100%
(25/91) обновление libgxps                         [################] 100%
(26/91) обновление poppler-glib                    [################] 100%
(27/91) обновление evince                          [################] 100%
(28/91) обновление v4l-utils                       [################] 100%
Новые дополнительные зависимости для v4l-utils
    qt4
(29/91) обновление ffmpeg                          [################] 100%
(30/91) обновление file-roller                     [################] 100%

manjaro.png

Ещё  и Pamac пропал из трея. Что можно сделать?

В консоли его запустить и посмотреть на что он будет матерится...

Вне форума

#3 08-03-2013 03:36:03

redix
Участник
Откуда: Shangri-La
Здесь с 14-02-2013
Сообщений: 2,398
LinuxChrome 25.0

Re: Не могу обновить Manjaro linux (решено)

Порешал. Для начала удалил конфликтующие пакеты, а потом очистил кеш и обновление пошло. Возможно просто попал на момент каких- то изменений в AUR. Что- то наподобие было под Centos. Спасибо за ответ. А Pamac висел в процессах почему- то в двух экземплярах, а после очистки кеша появился.

Отредактировано redix (08-03-2013 03:39:07)


In Tux We Trust

Вне форума

#4 08-03-2013 11:56:36

posixru
Модератор
Откуда: СССР
Здесь с 21-10-2010
Сообщений: 1,448
Сайт
LinuxSeaMonkey 2.16

Re: Не могу обновить Manjaro linux (решено)

Замена пакета "qt" на "qt4" (аrchlinux.org.ru/forum)
Из зарубежного:

A new qt4 package in [extra]. This replaces the current qt package.

All packages depending on qt need to be rebuilt to depend on qt4. We have done this for all official packages, but you will need to rebuild packages installed from the PCR that depend on qt.

Qt 5.x is now also available in [extra]. When you install both qt5-base and qt4 any Qt tool will refer to the 5.x version. We provide *-qt4 symlinks so you can explicitly force the 4.x version when you need it.

Не думал я что в Manjaro косяк пропустят... Обычно перед большим обновлением приходил маньяро-пакет с скриптами автоматом решающие проблемы. А тут как то... Расстроило меня это...

Вне форума

#5 09-03-2013 11:18:59

redix
Участник
Откуда: Shangri-La
Здесь с 14-02-2013
Сообщений: 2,398
LinuxChrome 25.0

Re: Не могу обновить Manjaro linux (решено)

Я читал это сообщение т.к. сразу полез в AUR, Archwiki и ещё не помню куда. Но тут есть положительный момент. У меня был установлен Google-earth, который не работал с самого начала, а после установки обновлений случайно кликнул и о, чудо! запустилось, да еще со вменяемыми русскими шрифтами!


In Tux We Trust

Вне форума

#6 09-03-2013 12:37:19

posixru
Модератор
Откуда: СССР
Здесь с 21-10-2010
Сообщений: 1,448
Сайт
LinuxSeaMonkey 2.16

Re: Не могу обновить Manjaro linux (решено)

Несколько софин, перед обновлением, запросили такое:

qt.png

Пришлось их требование удовлетворить! acute.gif Теперь имеем, то что имеем:

qt2.png

Вне форума

Сейчас в этой теме пользователей: 0, гостей: 1
[Bot] CCBot

Подвал форума

Под управлением FluxBB
Модифицировал Visman

[ Сгенерировано за 0.016 сек, 13 запросов выполнено - Использовано памяти: 1.65 Мбайт (Пик: 1.76 Мбайт) ]