Zenway

Linux - это интересно!

Вы не вошли.

#26 23-12-2017 21:35:07

BigOrange
Модератор
Откуда: Саратов
Здесь с 20-11-2010
Сообщений: 2,299
LinuxUnknown

Re: Аудиоконвертер

@KOT040188, хорошо
это часто на дебъяновых системах происходит, когда при обновлении из-за неразрешимых зависимостей удаляется пакет.
а если его поставить вручную из консольки, на что ругается?

Добавлено спустя 19 мин 29 с:
после перехода на арч совсем забыл о существовании этого ресурса
вот же он родимый https://pkgs.org/download/soundkonverter


Долой DE! Даёшь WM!

Вне форума

#27 23-12-2017 22:11:28

KOT040188
Участник
Здесь с 16-11-2016
Сообщений: 56
AndroidYaBrowser 17.10

Re: Аудиоконвертер

BigOrange пишет:

а если его поставить вручную из консольки, на что ругается?

На отсутствие. Вот ещё ссылочка https://packages.ubuntu.com/search?keyw … ection=all. В 17.10 этот пакет выкинули на мороз.

Добавлено спустя 02 мин 18 с:

BigOrange пишет:

вот же он родимый

Забавно, последняя бубунта там 12.04…

Отредактировано KOT040188 (23-12-2017 22:12:14)

Вне форума

#28 23-12-2017 22:33:57

BigOrange
Модератор
Откуда: Саратов
Здесь с 20-11-2010
Сообщений: 2,299
LinuxUnknown

Re: Аудиоконвертер

KOT040188 пишет:

Забавно, последняя бубунта там 12.04

но есть же, или он нерабочий?
или не устанавливается?
от debian тоже подойдёт
но версия старенькая да, похоже он давно никому не нужен кроме арчеводов и альтовцев ))

зы
дедбиф научил переменному битрейту в ogg
нужен пакет vorbis-tools
lTE4OZll.png
ещё есть вариант

--managed Enable the bitrate management engine. This will allow much greater control over the precise bitrate(s) used, but encoding will be much slower. Don't use it unless you have a strong need for detailed control over bitrate, such as for streaming.

-m, --min-bitrate Specify a minimum bitrate (in kbps). Useful for encoding for a fixed-size channel. Using this will automatically enable managed bitrate mode (see --managed).

-M, --max-bitrate Specify a maximum bitrate in kbps. Useful for streaming applications. Using this will automatically enable managed bitrate mode (see --managed).

но пока не пробовал (тут с примерами https://linux.die.net/man/1/oggenc)

Отредактировано BigOrange (23-12-2017 22:34:21)


Долой DE! Даёшь WM!

Вне форума

#29 23-12-2017 22:47:46

KOT040188
Участник
Здесь с 16-11-2016
Сообщений: 56
AndroidYaBrowser 17.10

Re: Аудиоконвертер

BigOrange пишет:

но есть же, или он нерабочий?

Если бы всё было так просто, то его можно было бы собрать для 17.10. Но всё сложно.

Вне форума

#30 23-12-2017 22:54:16

posixru
Модератор
Откуда: СССР
Здесь с 21-10-2010
Сообщений: 1,448
Сайт
LinuxSeaMonkey 2.49

Re: Аудиоконвертер

KOT040188 пишет:

Ну пропустил. Что дальше? Оштрафуете?

Зачем мне это? Из за неправильно отписанного названия хуже ведь вам а не мне...

KOT040188 пишет:

Генту забыли, для полноты картины.

Как я мог забыть про то чего у меня нет?
Хотя, вы это видимо с "намёком" на их сложность и недружелюбность по сравнению с Убунтой? Я вас жестоко разочарую, Арчик, Гента и Слака много проще и логичнее всех остальных пород пингвинов. Вот хоть на вашем примере посмотрите, это ведь у вас в Убнте проблема, а в них её нет, так кто/что в самом деле для ...

KOT040188 пишет:

Я ссылку не просто так дал. Там грамотный человек пытался собрать его, но не смог.

По ссылке не ходил, не мне судить, но судя по отсутствию результата грамотность довольно сомнительна.

KOT040188 пишет:

Я очень со наведаться, что в 18.04 случится чудо и конвертер воскреснет.

Удачно получилось, позавчера припёрли на починку ноут Acer TravelMate B113, вспомнив прочтение ЭТОГО стало интересно и я решил его с помощью 17.10 проверить "по тому поводу", а за одно и на предмет этого обсуждения осмотреть...
Так как я не являюсь грамотным убунтоводом, я не знаю как в ней делается правильно, в смысле идеологически верно, потому пошел по пути наименьшего сопротивления.
Главное что? Правильно, нужна рабочая софина, потому закатываем губу рукава и начинаем! Для начала взял из 16.04 версию 2.1.2 и подсовыванием пары библиотек её поставил. Проверил, работает! Но есть ведь свежее версия, ну и стянул версию 3.0.1-2 что для openSUSE, взял чужого (alien) за ноги и об дерево его башкой, об дерево:
uba-001.png
Пришлось ещё пару пакетов с libQt5Core конвертнуть и опять заработала софина!
Удалил, решив пакетака из Арчика конвертнуть и поставить:
uba-002.png
uba-003.png
Как не странно, но опять всё заработало:
uba-004.jpg
Проверять ещё несколько известных способов мне стало банально не интересно...
Кстати, сделанная в Арчике с помощью CDE портабле версия тоже работает.

Скрытый текст

Вывод? Тот кому надо делает, а кому не надо ищет причины...

Вне форума

#31 24-12-2017 02:13:00

KOT040188
Участник
Здесь с 16-11-2016
Сообщений: 56
AndroidYaBrowser 17.10

Re: Аудиоконвертер

posixru пишет:

Я вас жестоко разочарую, Арчик, Гента и Слака много проще и логичнее всех остальных пород пингвинов. Вот хоть на вашем примере посмотрите, это ведь у вас в Убнте проблема, а в них её нет

Странная у вас логика. В этих ваших арчиках пакет есть, значит они простые. В бубунте пакета нет, значит она сложная? Мне казалось сложность определяется не только наличием одного пакета.

posixru пишет:

По ссылке не ходил, не мне судить, но судя по отсутствию результата грамотность довольно сомнительна.

Ну уж всяко грамотнее меня.

posixru пишет:

Вывод? Тот кому надо делает, а кому не надо ищет причины...

Вы что-то напутали, я ищу альтернативу приложению. Мне не надо искать никакие причины чего-то там. У меня конкретная цель, конкретный вопрос. Ваша инициатива по сборке приложения на коленке конечно похвальна, но бесполезна…

Добавлено спустя 56 мин 22 с:
По поводу sounconveter выяснилось, что если скормить ему больше 100 файлов, он начинает адски насиловать процессор, в результате чего у меня висеть плазма до конца процесса конвертирования.

Вне форума

#32 24-12-2017 13:03:28

BigOrange
Модератор
Откуда: Саратов
Здесь с 20-11-2010
Сообщений: 2,299
LinuxUnknown

Re: Аудиоконвертер

получилось вкорячить на кубнту 17,10 этот самый "тухлый" саундКонвертер для Debian9
2017122415_4881369_28773497.jpg
https://debian.pkgs.org/9/debian-main-a … 4.deb.html
там же потребовалось скачать всего 2 зависимости
установилось в таком порядке:
libkcompactdisc4
libkcddb4
soundkonverter


Долой DE! Даёшь WM!

Вне форума

#33 29-12-2017 19:12:49

redix
Участник
Откуда: Shangri-La
Здесь с 14-02-2013
Сообщений: 2,398
LinuxChrome 62.0

Re: Аудиоконвертер

Роботать с ogg форматом умеет встроенный конвертер Clementine. Постоянный/переменный битрейт тоже умеет.

s_1514560073_8294994_c80aa3f77a.png s_1514560325_5171943_e98bb33717.png s_1514560342_2913818_81caded9da.png


In Tux We Trust

Вне форума

#34 29-12-2017 20:31:26

KOT040188
Участник
Здесь с 16-11-2016
Сообщений: 56
LinuxYaBrowser 17.10

Re: Аудиоконвертер

Странный народ линуксоиды. Завинчивают гвозди и забивают шурупы…

Вне форума

#35 29-12-2017 22:14:18

redix
Участник
Откуда: Shangri-La
Здесь с 14-02-2013
Сообщений: 2,398
LinuxChrome 62.0

Re: Аудиоконвертер

Ничего странного, мне этого хватает, когда возникнет потребность, тогда и буду искать, а будет надо и вендовоз установлю.


In Tux We Trust

Вне форума

#36 30-12-2017 10:10:09

BigOrange
Модератор
Откуда: Саратов
Здесь с 20-11-2010
Сообщений: 2,299
LinuxUnknown

Re: Аудиоконвертер

KOT040188 пишет:

Странный народ линуксоиды. Завинчивают гвозди и забивают шурупы…

неправда, настоящие линуксоиды делают так:

"This is the Unix philosophy: - Write programs that do one thing and do it well. - Write programs to work together. - Write programs to handle text streams, because that is a universal interface."

Отредактировано BigOrange (30-12-2017 10:10:22)


Долой DE! Даёшь WM!

Вне форума

#37 30-12-2017 19:26:22

posixru
Модератор
Откуда: СССР
Здесь с 21-10-2010
Сообщений: 1,448
Сайт
LinuxSeaMonkey 2.49

Re: Аудиоконвертер

KOT040188 пишет:

Странная у вас логика. В этих ваших арчиках пакет есть, значит они простые. В бубунте пакета нет, значит она сложная? Мне казалось сложность определяется не только наличием одного пакета.

Это не логика, это просто опыт использования, лично я почти все породы пингвинов имел возможность выпасать, раньше даже желание было этим заниматься, это сейчас то время нет то лень...
А про один пакет, так это показатель применительно к вашему случаю. Начиная где то с Убунты 12.04 в ней сложно стало ставить что то стороннее, то чего нет в репах, даже ППА нередко создавали дикие косяки. А чем дальше, тем всё больше ситуация извращалась. Сейчас в ней очень много стало "специфического", отличающего её от "традиционных" пингвинов, что диву иногда даюсь зачем надо было извращаться.
Да, если использовать на уровне "хватает того что в репах" то все пингвины практически одинаковы для пользователя, ну того что просто катается и под капот не заглядывает. Лично мне интересно заглядывать, вот и пользую Арчика на поглядеть что самое свежее и молодёжное, а Слаку на то что просто работала, редко чего в неё из Арчика перетягиваю, самые вкусные и/или полезные кусочки.

KOT040188 пишет:

Вы что-то напутали, я ищу альтернативу приложению. Мне не надо искать никакие причины чего-то там. У меня конкретная цель, конкретный вопрос.

Не надо "альтернативы" искать, описали бы внятно ваши "желания" и вам бы рассказали как их реализовать. А на расписывание "жалоб" лично я даже и не знаю что отвечать... В этой это не так, в той то не эдак, раньше было хорошо а сейчас не очень, мне хочется чтобы лучше было, а не кто мне этого не делает! Как то так...
Вот почему на варезниках про софт таких стонов нет? Никогда не встречал подобного нытья, пользуют то что разработчиками дадено, молчком, разве что проблемы с кряками обсуждают. А к свободному софту вечно доебушки притенении предъявляют, то то не так, а почему это не эдак. Люди делают как им надо а не как кому то хочется, а их выставляют как будто они кому то должны, с какого перепуга?

KOT040188 пишет:

Ваша инициатива по сборке приложения на коленке конечно похвальна, но бесполезна…

Так я не для вас делал а для себя, пригодится кому хорошо, если нет так мне совершенно на это ультрафиолетово...

KOT040188 пишет:

По поводу sounconveter выяснилось, что если скормить ему больше 100 файлов, он начинает адски насиловать процессор, в результате чего у меня висеть плазма до конца процесса конвертирования.

Больше трёх сотен файлов пережевал нормально, никаких затруднений при использовании других приложений я не ощутил, но это на Арчике Опенбокснутом, жаль ноут с Убунтой уже отдал и нет возможности на ней опробовать.

KOT040188 пишет:

Странный народ линуксоиды. Завинчивают гвозди и забивают шурупы…

А виндузоиды разве другие? Просто у них отвёртки нежно голубые а молотки влажно розовые...

Вне форума

#38 30-12-2017 22:59:20

KOT040188
Участник
Здесь с 16-11-2016
Сообщений: 56
LinuxYaBrowser 17.10

Re: Аудиоконвертер

posixru пишет:

Начиная где то с Убунты 12.04 в ней сложно стало ставить что то стороннее, то чего нет в репах, даже ППА нередко создавали дикие косяки

Давай оюойдёмся без сочинения сказок. Я не виндузятник, не верю в них. Про косяки с ppa я не вкурсе, хотя пользуюсь ими с 2013 года. Арчик я пробовал. Конечно не в чистом виде, там даже инсталятора нет. Манджаро все хвалят. Выглядит неплохо. Но пакетная база скромная. Даже в ауре нет кое-чего, что у меня есть в виде deb. Я у же молчу про то, что не всегда из аура можно установить без ошибок.

posixru пишет:

описали бы внятно ваши "желания"

Я уже всё отписал. Мне нужен конвертер, который не будет насиловать мой i5 процессор и вешать систему. Гномовский если ему скормить более 100 файлов вешает плазму.

Вне форума

#39 30-12-2017 23:27:03

redix
Участник
Откуда: Shangri-La
Здесь с 14-02-2013
Сообщений: 2,398
LinuxChrome 62.0

Re: Аудиоконвертер

KOT040188 пишет:

Даже в ауре нет кое-чего, что у меня есть в виде deb.

Вот потому что в манжарах все искаропке, те кто ее юзают и не в курсе, что есть такая утилитка, под названием debtap, которая из любого деб-пакета делает пакет для Арчика. Так что мимо, есть АУР + все пакеты от дебиана\бубунты. А то что могут быть косяки со сборкой пакетов из АУР, да они бывают, только можно всегда пнуть сопровождающего, или поправить pkgbuild ручками, или просто почитать комментарии к пакету.


In Tux We Trust

Вне форума

#40 31-12-2017 00:39:18

posixru
Модератор
Откуда: СССР
Здесь с 21-10-2010
Сообщений: 1,448
Сайт
LinuxSeaMonkey 2.49

Re: Аудиоконвертер

KOT040188 пишет:

Давай оюойдёмся без сочинения сказок. Я не виндузятник, не верю в них

Какие сказки, это просто выводы на основе ваших комментариев.
Вопрос веры или неверия сугубо индивидуален и очень редко соответствует реальности.

KOT040188 пишет:

Мне нужен конвертер, который не будет насиловать мой i5 процессор и вешать систему

А MEncoder или FFmpeg чем не устраивают? Если вы действительно не тот от кого открещивались выше, то в чём проблема? Имеется по ним куча документации, в том числе на русском, а число готовых однострочников и скриптов вообще счёту не поддаётся.
Предвижу "возмущение" и сразу отвечаю, вам шашечки или ехать?
И да, а почему бы вам просто не уменьшить аппетит конвертера, с помощью cpulimit например?
В той же Убунте он кажется дефолтно поставляется, или поставлялся, в репах то имеется полюбому.

Вне форума

#41 31-12-2017 00:43:53

KOT040188
Участник
Здесь с 16-11-2016
Сообщений: 56
LinuxYaBrowser 17.10

Re: Аудиоконвертер

posixru пишет:

это просто выводы на основе ваших комментариев

Я не понял что можно вывести из моих сообщений, но я пробовал ваши "арчики", не надо ничего про них рассказывать. Не надо!

posixru пишет:

А MEncoder или FFmpeg чем не устраивают?

Они консольные. Мне нужен графический конвертер.

Вне форума

#42 31-12-2017 00:46:55

posixru
Модератор
Откуда: СССР
Здесь с 21-10-2010
Сообщений: 1,448
Сайт
LinuxSeaMonkey 2.49

Re: Аудиоконвертер

KOT040188 пишет:

Я не понял что можно вывести из моих сообщений

Я ещё с нонейма научился определять "наклонности" человека по паре его комментариев.

KOT040188 пишет:

Они консольные. Мне нужен графический конвертер

Почему?

Вне форума

#43 31-12-2017 00:48:57

KOT040188
Участник
Здесь с 16-11-2016
Сообщений: 56
LinuxYaBrowser 17.10

Re: Аудиоконвертер

posixru пишет:

Почему?

Я хурму не ем. Не нравится она мне. Намёк поняли?

Вне форума

#44 31-12-2017 01:06:29

posixru
Модератор
Откуда: СССР
Здесь с 21-10-2010
Сообщений: 1,448
Сайт
LinuxSeaMonkey 2.49

Re: Аудиоконвертер

KOT040188 пишет:

Я хурму не ем. Не нравится она мне. Намёк поняли?

Судя по вашим отзывам всё же кушаете, морщитесь и возмущаетесь но кушаете...
Ну возьмите мяса, приготовьте его по предлагаемым рецептам и порадуйте желудок!
А как распробуете, так ещё и свои рецепты составлять будите, утончённые...

Вне форума

#45 31-12-2017 01:21:05

KOT040188
Участник
Здесь с 16-11-2016
Сообщений: 56
LinuxYaBrowser 17.10

Re: Аудиоконвертер

Я сало ем. С капустой. И не морщусь.

Вне форума

#46 31-12-2017 01:49:55

posixru
Модератор
Откуда: СССР
Здесь с 21-10-2010
Сообщений: 1,448
Сайт
LinuxSeaMonkey 2.49

Re: Аудиоконвертер

KOT040188 пишет:

Я сало ем. С капустой. И не морщусь

Так а я о чём, на вкус и цвет карамельки разные, а ириски так вообще!

Вне форума

Сейчас в этой теме пользователей: 0, гостей: 1
[Bot] CCBot

Подвал форума

Под управлением FluxBB
Модифицировал Visman

[ Сгенерировано за 0.019 сек, 9 запросов выполнено - Использовано памяти: 1.74 Мбайт (Пик: 1.81 Мбайт) ]