Linux -- это интересно

Blam


Рубрика: Интернет ПО
Метки: | | | | |
Просмотров: 2826

Blam — очень простой и лёгкий GTK (Gnome) графический RSS-агрегатор (сборщик новостных лент).

RSS-агрегатор — клиентское приложение для автоматического сбора сообщений из источников экспортирующих форматы RSS (семейство XML-форматов предназначенных для описания новостных лент, анонсов статей, изменений в блогах и прочее) или Atom (формат для описания ресурсов и протокол публикации новостей).

Blam имеет простой пользовательский интерфейс, минимум настроек, интегрируется в область уведомлений и поддерживает смену темы оформления интерфейса (изначально доступно четыре темы). Пользователю достаточно ввести в Blam адреса интересующих источников (на несколько СПО ресурсов сразу есть подписка) и задать необходимый интервал обновления (обновление возможно и по требованию пользователя).

Собранные новости Blam собирает и отображает в окне, собираются обновления в фоновом режиме, никаких оповещений о наличии новостей у агрегатора нет (отображает их количество только при наведении курсора на значок в трее). Есть возможность подключения к закрытым RSS-каналам (требующим авторизации).

Пользовательский набор новостных лент может быть импортирован и экспортирован в файл формата OPML (стандарт для создания списков включающих RSS-потоки).

Лицензия: GNU GPL v2

Домашняя страница

Страница на ftp.gnome.org

Комментариев: 6 RSS

хотел глянуть, но сие чудо кучу моно захотело...

Странно... В Арче он без МОНО:

https://www.archlinux.org/packages/community/any/blam/

Requires:
gconf-sharp
hicolor-icon-theme
notify-sharp
webkit-sharp
xdg-utils

А в Убунте МОНО хочет:

http://pkgs.org/ubuntu-12.10/ubuntu-universe-i386/blam_1.8.9-2ubuntu1_all.deb.html

Requires
    gconf2 (>= 2.28.1-2)
    libc6 (>= 2.13) | libc6.1 (>= 2.13) | libc0.1 (>= 2.13)
    libgconf2.0-cil (>= 2.24.0)
    libglade2.0-cil (>= 2.12.10-1ubuntu1)
    libglib2.0-cil (>= 2.12.10-1ubuntu1)
    libgnome2.24-cil (>= 2.24.0)
    libgtk2.0-cil (>= 2.12.10-1ubuntu1)
    libmono-corlib4.0-cil (>= 2.10.1)
    libmono-posix4.0-cil (>= 2.10.1)
    libmono-system-web4.0-cil (>= 2.10.3)
    libmono-system-xml4.0-cil (>= 1.0)
    libmono-system4.0-cil (>= 2.10.1)
    libwebkit1.1-cil (>= 0.3)
    mono-runtime (>= 2.10.1)

В ROSA тоже МОНО не надо... Хм, как то и не обратил внимания...

Давно оно mono хочет:

The dependencies are: mono, gconf and libgnomeui development packages.

и

commit 489c43a8ef1798b4445c3cb7cb19d5bd8f92d6c4
Author: Mikael Hallendal
Date: 2005-12-18 15:25:31 +0000
Require Mono 1.1.10 Splitted out from Channel.cs Split out Item class Use
крокодил5 2016-06-11 в 19:33:08

ээээ..........

==> Сборка и установка пакета
==> Установить или собрать отсутствующие зависимости yarssr:
разрешение зависимостей...
проверка конфликтов...
Пакеты (50) cairo-perl-1.106-1  glib-perl-1.321-1  gnome-vfs-perl-1.082-3  gnomecanvas-perl-1.002-13
            libart-lgpl-2.3.21-3  libbonobo-2.32.1-4  libbonoboui-2.24.5-3  libgnome-2.32.1-6
            libgnome-data-2.32.1-6  libgnomecanvas-2.30.3-3  libgnomeui-2.24.5-2  libidl2-0.8.14-3
            orbit2-2.14.19-3  pango-perl-1.227-1  perl-b-hooks-endofscope-0.15-1  perl-class-load-0.23-1
            perl-class-singleton-1.5-1  perl-data-optlist-0.110-1  perl-datetime-1.25-1
            perl-datetime-format-mail-0.402-1  perl-datetime-format-w3cdtf-0.06-2
            perl-datetime-locale-1.02-1  perl-datetime-timezone-1.95-1  perl-dist-checkconflicts-0.11-1
            perl-exporter-tiny-0.042-1  perl-html-parser-3.72-1  perl-html-tagset-3.20-4
            perl-inc-latest-0.500-1  perl-list-allutils-0.09-1  perl-list-moreutils-0.415-1
            perl-math-round-0.07-1  perl-module-build-0.4218-1  perl-module-implementation-0.09-1
            perl-module-runtime-0.014-3  perl-namespace-clean-0.26-1  perl-package-stash-0.37-2
            perl-package-stash-xs-0.28-3  perl-params-util-1.07-4  perl-params-validate-1.22-1
            perl-sub-exporter-0.987-1  perl-sub-exporter-progressive-0.001011-1  perl-sub-install-0.928-1
            perl-test-fatal-0.014-1  perl-try-tiny-0.24-1  perl-variable-magic-0.59-1  glade-perl-1.007-9
            gnome-perl-1.045-3  gtk2-perl-1.2498-1  perl-gtk2-trayicon-0.06-12  perl-xml-rss-1.59-1
Будет загружено:   8,39 MiB
Будет установлено:  43,69 MiB
Оставьте комментарий!
Используйте нормальные имена.Войти через loginza
Если вы уже зарегистрированы как комментатор или хотите зарегистрироваться, укажите пароль и свой действующий email.
(При регистрации на указанный адрес придет письмо с кодом активации и ссылкой на ваш персональный аккаунт, где вы сможете изменить свои данные, включая адрес сайта, ник, описание, контакты и т.д.)



 
(обязательно)