Linux -- это интересно

UTube Ripper / gvdown


Рубрика: Интернет ПО
Метки: | | | | |
Просмотров: 4677

Инструменты скачивания и конвертирования видео с YouTube.


UTube Ripper - небольшая утилита для Gnome, основанная на Gambas2 и предназначенная для скачивания видеороликов с YouTube.

UTube Ripper - позволяет перекодировать flv файлы в другие форматы, но эта функция не привязана к скачиваемому файлу и может использоваться автономно. Кроме того UTube Ripper позволяет "выдернуть" звуковую дорожку из видеофайла в mp3.

Лицензия: GNU General Public License (GPL)


Страница проекта

gvdown - простой GTK графический интерфейс к vdown, консольной утилите для скачивания роликов с видеосервисов. Написана на Python. Помимо YouTube, позволяет качать ролики с таких сайтов, как: MySpace Video, Google Video, Stage6 и других...

gvdown - может сразу перекодировать ролик в нужный формат (в настройках задается строка с функциями кодирования). При сохранении gvdown присваивает файлам нормальные имена/названия с сайта.

Лицензия: GNU General Public License v3

Домашняя страница

Комментариев: 7 RSS

на странице проекта лежит пакет .deb и совершенно не понять какие пакеты к нему ставить надо, чтоб работало, обозначили бы хотя бы

А вы до сих пор .deb пакеты на старую Слаку ставите? =) По моему уже давно все .deb базед дистры зависимости ставят автоматом, перед установкой показывая их список и самому не требуется их выискивать!

ЗЫ: Зависимости gvdown можмо почитать распаковав пакет архиатором или на сайте проекта посмотрев на правый-верхний угол!

кругом одни умные

где оно?

http://packages.debian.org/search?keywords=gvdown&search

http //packages.ubuntu.com/search?keywords=gvdown&search

где ссылка на его репозиторий, раз он дебиановый?

и какие там в зависимостях версии?

python, web, gtk, youtube, video, cli, pygtk, linux, windows - вот ваш "правый-верхний угол!" с отсылкой в гугл

какие версии пакетов ему надо?

python-glade2, python-gtk2 - вот файл control

почему его не ест gdebi раз он .deb ?

какой автомат ещё нужен?

почему при запуске ругань на отсутствие PyGTKv2

где оно? http://packages.ubuntu.com/search?suite=all&arch=i386&search

http //packages.debian.org/search?search

PS python-gtk2 python-zbarpygtk и всё перечисленное в системе стоит

Вот именно по этой причине и не даются никакие инструкции по установке, тем более на Ubuntu... А только "Домашняя страница". Не все используют Ubuntu, да и она сама каждые полгода меняется и осень сильно... Какой был бы толк сейчас если бы я в марте дал ссылки на тогдашний репозиторий? Нулевой!Вот потому и... А вопрос по PyGTKv2 давно был решен, в мае если не ошибаюсь, на форуме Ubuntu. Решения проблем своего дистрибутивыа лучше искать на его родном форуме, хотя скорее всего там уже всё решено! А я не ставлю перед собой задачу создания универсальных инструкций, я лишь уведомляю что такая программа есть и она работоспособна. А проверять как она работает и составлять инструкции для всех дистров, всех релизов у меня просто нет физической возможности!

убунта 10.04.1. Скачал gvdown-0.6.5_all.deb, попробовал установить:

sudo dpkg -i gvdown-0.6.5_all.deb
Выбор ранее не выбранного пакета gvdown.
(Чтение базы данных ... на данный момент установлено 211263 файлов и каталогов.)
Распаковывается пакет gvdown (из файла gvdown-0.6.5_all.deb)...
dpkg: зависимости пакетов не позволяют настроить пакет gvdown:
 gvdown зависит от python (<< 2.6), однако:
  Версия python в системе 2.6.5-0ubuntu1.
dpkg: не удалось обработать параметр gvdown (--install):
 проблемы зависимостей -- оставляем не настроенным
Обрабатываются триггеры для desktop-file-utils ...
Обрабатываются триггеры для python-gmenu ...
Rebuilding /usr/share/applications/desktop.ru_RU.utf8.cache...
Обрабатываются триггеры для python-support ...
При обработке следующих пакетов произошли ошибки:
 gvdown

Как видим, поставилось, но с ошибкой. Пробуем запустить:

$ gvdown
/usr/bin/env: python2.5: Нет такого файла или каталога

Ну да это и понятно. Делаем:

sudo ln -s /usr/bin/python2.6 /usr/bin/python2.5

и снова пробуем:

$ gvdown
Config file /home/vovans/.gvdownrc not found. Creating one for you...
Setting settings to default...

Запускается. Но это ещё ни о чём не говорит. Пробуем что-то скачать и смотрим в консоль:

----
Trying to download http://www.youtube.com/watch?v=m7LJpqNiHHo
YouTube: data line not found
----

В общем, на ютубе не так давно менялись некоторые вещи, из-за которых, в частности, перестал работать minitube версии 1.0. В следствии сего авторы minitube спешно выпустили 1.1, который работает!

Я бы не сильно рассчитывал на сабж. Удаляем пакет, симлинк и забиваем :)

Кстати, для FireFox есть плагин - Video DownloadHelper. И никакой мороки :)

http://forum.ubuntu.ru/index.php?topic=56550.0 - вот вся инфа на форуме по запросу

glade также есть в системе

вывод: либо так собран .deb пакет либо не указаны все зависимости

тогда какой смысл такой сборки?

Оставьте комментарий!
Используйте нормальные имена.Войти через loginza
Если вы уже зарегистрированы как комментатор или хотите зарегистрироваться, укажите пароль и свой действующий email.
(При регистрации на указанный адрес придет письмо с кодом активации и ссылкой на ваш персональный аккаунт, где вы сможете изменить свои данные, включая адрес сайта, ник, описание, контакты и т.д.)



 
(обязательно)