Zenway

Linux - это интересно!

Вы не вошли.

#1 20-01-2017 22:16:36

BigOrange
Модератор
Откуда: Саратов
Здесь с 20-11-2010
Сообщений: 1,657
Сайт
LinuxUnknown

Arch ядро aur/linux-libre-rt ругается на ключи

Подскажите пожалуйста!
хотел ядро (linux-libre-rt) кастомное поставить, а тут говорят ключи не те.

==>Проверка подписей исходных файлов с помощью 'gpg'...
    linux-4.8.tar ... СБОЙ (неизвестный открытый ключ 79BE3E4300411886)
    patch-4.8.15 ... СБОЙ (неизвестный открытый ключ 38DBBDC86092693E)
    patch-4.8.15-rt10.patch ... СБОЙ (неизвестный открытый ключ 7B96E8162A8CF5D1)
==> ОШИБКА: Одна или больше PGP-подписей не могут быть проверены!
Скрытый текст
~$ yaourt -S linux-libre-rt bbswitch-rt nvidia-rt

==> Загрузка PKGBUILD bbswitch-rt из AUR...
x .SRCINFO
x PKGBUILD
x bbswitch-rt.install
fraunos commented on 2015-12-29 00:12			 
is it ONLY for 4.0 kernel?

jhernberg commented on 2015-12-30 09:58			 
@fraunos: Change the line saying _extramodules=extramodules-4.0-rt to _extramodules=extramodules-4.1-rt

Otherwise IIRC the bbswitch-git package works for all kernels, but the best nvidia/bbswitch packages to use with linux-rt and other kernels are the dkms ones, which (again IIRC) work with all kernels and don't need any specific per kernel packages.

dvzrv commented on 2015-12-30 13:25			 
@jhernberg, fraunos: Thanks for the heads up! I just updated it.
Got way too busy doing other things the past few weeks. Sorry.

dvzrv commented on 2016-09-22 18:08			 
Updated. Seems to become a meme, me updating this late. Sorry again.

bbswitch-rt 0.8-10  (2016-11-15 14:18)
( Неподдерживаемый пакет: Потенциально опасен ! )
==> Отредактировать PKGBUILD ? Да/нет [Y/n] ("A" для отмены)
==> --------------------------------------------------------
==> n

==> зависимости bbswitch-rt:
 - linux-rt>=4.8 (сборка из AUR)
 - linux-rt<4.9 (сборка из AUR)
 - linux-rt-headers>=4.8 (сборка из AUR) [makedepend]
 - linux-rt-headers<4.9 (сборка из AUR) [makedepend]


==> Отредактировать bbswitch-rt.install ? Да/нет [Y/n] ("A" для отмены)
==> -------------------------------------------------------------------
==> n

==> Продолжить сборку bbswitch-rt ? Да/нет [Y/n]
==> --------------------------------------------
==> y

==> Сборка и установка пакета
==> Установить или собрать отсутствующие зависимости bbswitch-rt:

==> Загрузка PKGBUILD linux-rt из AUR...
x .SRCINFO
x PKGBUILD
x change-default-console-loglevel.patch
x config
x config.x86_64
x fix-race-in-PRT-wait-for-completion-simple-wait-code_Nvidia-RT-160319.patch
x linux-rt.install
x linux-rt.preset
alcomatt commented on 2016-11-07 22:06			 
nvidia-rt from AUR fails to build with this kernel. 

The error in make.log: 

d -r -o /var/lib/dkms/nvidia/375.10/build/nvidia-modeset/nv-modeset-interface.o /var/lib/dkms/nvidia/375.10/build/nvidia-modeset/nvidia-modeset-linux.o
LD [M]  /var/lib/dkms/nvidia/375.10/build/nvidia.o
LD [M]  /var/lib/dkms/nvidia/375.10/build/nvidia-modeset.o
LD [M]  /var/lib/dkms/nvidia/375.10/build/nvidia-drm.o
LD [M]  /var/lib/dkms/nvidia/375.10/build/nvidia-uvm.o
Building modules, stage 2.
MODPOST 4 modules
FATAL: modpost: GPL-incompatible module nvidia-drm.ko uses GPL-only symbol 'rt_mutex_destroy'
make[2]: *** [scripts/Makefile.modpost:91: __modpost] Error 1


looks like this might fix it (not tested it though it): https://forums.gentoo.org/viewtopic-p-7957150.html?sid=e2cd6b59f94069b9133e189d30feb3cb


blackhole commented on 2016-11-07 22:18			 
The "dirty" trick... 

Go to 
/var/lib/dkms/nvidia/375.10/source/nvidia-drm/
Substitute MIT with GPL in
nvidia-drm-linux.c
Recompile with
dkms autoinstall -k 4.8.6_rt5-1-rt

alcomatt commented on 2016-11-07 22:50			 
Hah, dirty but works, thanks !

jhernberg commented on 2016-11-13 11:46			 
@alcomatt:  This is a pain, and not the first time it happens..  Not quite sure what the right fix is, would be better fixed upstream, rather than patched by us in either linux-rt or nvidia packages.  I'll see what can be done.

jhernberg commented on 2016-11-13 11:48			 
Please don't flag as out of date when it isn't..!  There is no patch available for 4.8.7-rt, only for 4.8.6-rt.  See: https://www.kernel.org/pub/linux/kernel/projects/rt/4.8/

linux-rt 4.8.15_rt10-1  (2016-12-30 16:31)
( Неподдерживаемый пакет: Потенциально опасен ! )
==> Отредактировать PKGBUILD ? Да/нет [Y/n] ("A" для отмены)
==> --------------------------------------------------------
==> n

==> ВНИМАНИЕ: Данный PKGBUILD описывает разделенный пакет.
==> Неизвестные специфические параметры пакета
==> зависимости linux-rt:
 - xmlto (уже установлен) [makedepend]
 - docbook-xsl (уже установлен) [makedepend]
 - kmod (уже установлен) [makedepend]
 - inetutils (уже установлен) [makedepend]
 - bc (уже установлен) [makedepend]
 - libelf (уже установлен) [makedepend]


==> Продолжить сборку linux-rt ? Да/нет [Y/n]
==> -----------------------------------------
==> 

==> Сборка и установка пакета
==> Сборка пакета linux-rt 4.8.15_rt10-1 (Пт янв 20 21:53:33 +04 2017)
==> Проверка зависимостей для запуска...
==> Проверка зависимостей для сборки...
==> Получение исходных файлов...
  -> Загрузка linux-4.8.tar.xz...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 87.7M  100 87.7M    0     0  2396k      0  0:00:37  0:00:37 --:--:-- 3697k
  -> Загрузка linux-4.8.tar.sign...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   455  100   455    0     0    498      0 --:--:-- --:--:-- --:--:--   498
  -> Загрузка patch-4.8.15.xz...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  262k  100  262k    0     0   140k      0  0:00:01  0:00:01 --:--:--  140k
  -> Загрузка patch-4.8.15.sign...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   833  100   833    0     0    707      0  0:00:01  0:00:01 --:--:--   707
  -> Загрузка patch-4.8.15-rt10.patch.xz...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  159k  100  159k    0     0   125k      0  0:00:01  0:00:01 --:--:--  125k
  -> Загрузка patch-4.8.15-rt10.patch.sign...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   566  100   566    0     0    846      0 --:--:-- --:--:-- --:--:--   847
  -> Найден config
  -> Найден config.x86_64
  -> Найден linux-rt.preset
  -> Найден change-default-console-loglevel.patch
  -> Найден fix-race-in-PRT-wait-for-completion-simple-wait-code_Nvidia-RT-160319.patch
==> Проверка файлов source с использованием sha256sums...
    linux-4.8.tar.xz ... Готово
    linux-4.8.tar.sign ... Пропущено
    patch-4.8.15.xz ... Готово
    patch-4.8.15.sign ... Пропущено
    patch-4.8.15-rt10.patch.xz ... Готово
    patch-4.8.15-rt10.patch.sign ... Пропущено
    config ... Готово
    config.x86_64 ... Готово
    linux-rt.preset ... Готово
    change-default-console-loglevel.patch ... Готово
    fix-race-in-PRT-wait-for-completion-simple-wait-code_Nvidia-RT-160319.patch ... Готово
==> Проверка подписей исходных файлов с помощью 'gpg'...
    linux-4.8.tar ... СБОЙ (неизвестный открытый ключ 79BE3E4300411886)
    patch-4.8.15 ... СБОЙ (неизвестный открытый ключ 38DBBDC86092693E)
    patch-4.8.15-rt10.patch ... СБОЙ (неизвестный открытый ключ 7B96E8162A8CF5D1)
==> ОШИБКА: Одна или больше PGP-подписей не могут быть проверены!
==> ОШИБКА: Makepkg не смог собрать linux-rt.
==> Перезапустить сборку linux-rt ? да/Нет [y/N]
==> --------------------------------------------
==> 

как в таких случаях грамотно поступать следует?
как старому параноику ключи проверить?


Долой DE! Даёшь WM!

Вне форума

20-01-2017 22:16:36

google
реклама

Re: Arch ядро aur/linux-libre-rt ругается на ключи



#2 20-01-2017 23:03:14

redix
Участник
Здесь с 14-02-2013
Сообщений: 1,766
LinuxChrome 55.0

Re: Arch ядро aur/linux-libre-rt ругается на ключи

Вот вроде нормальное описание: http://jotham-city.com/blog/2015/02/14/ … r-makepkg/, ну и на bbs.archlinux.org решали: https://bbs.archlinux.org/viewtopic.php?id=152337.

Гы! Полез в аур глянуть на пакет, а там Биг уже отметился! )))


In Tux We Trust

Вне форума

#3 21-01-2017 10:12:40

BigOrange
Модератор
Откуда: Саратов
Здесь с 20-11-2010
Сообщений: 1,657
Сайт
LinuxUnknown

Re: Arch ядро aur/linux-libre-rt ругается на ключи

время свободное образовалось, настроился было кино посмотреть, а кино - оказалось говно.
вот и началось... ))


Долой DE! Даёшь WM!

Вне форума

Сейчас в этой теме пользователей: 0, гостей: 1
[Bot] CCBot

Подвал форума

Под управлением FluxBB
Модифицировал Visman

[ Сгенерировано за 0.009 сек, 10 запросов выполнено - Использовано памяти: 494.66 Кбайт (Пик: 579.57 Кбайт) ]