Linux -- это интересно

Salix Xfce 14.2


Рубрика: Дистрибутивы -> Hовости
Метки: | |
Просмотров: 414505

29 августа 2016 года было объявлено о выходе Salix Xfce 14.2

Salix OS — компактная и простая в использовании модификация дистрибутива Slackware Linux (являющийся с ним полностью обратно совместимой). Разработчиками Salix OS позиционируется как оптимальное решение для выполнения широкого круга задач, свойственных настольным компьютерам и ноутбукам (домашним или офисным), в том числе для применения рядовыми пользователями.

Процедура установки Salix напоминает стандартную установку Slackware, такой же консольный установщик но имеющий небольшие отличия внесённые разработчиками системы, частично упрощая процедуру. В установщик Salix Xfce 14.2 добавлена поддержка нескольких языков (установка на русском языке в релиз не вошла), ранее установка производилась только английском языке.

Установка Salix Xfce 14.2 отличается быстротой, функция "AUTOINSTALL" (режим автоматической разметки диска) из установщика исключёна, для разметки диска можно воспользоваться cfdisk.

Загрузочное меню Salix Xfce 14.2 обеспечивается Syslinux, на системах с UEFI-прошивками загрузка обеспечивается использованием ELILO (EFI Linux Boot Loader) и меню аналогичным SysLinux. Минимальная архитектура для 32-бит системы увеличена с i486 до i586, меню предоставляет выбор загрузки i586 non-PAE или i686 PAE ядра.

Традиционно поддерживается три режима установки:

  • FULL/Полная (рекомендуемый режим) – полнофункциональная версия рабочего окружения Xfce, полный набор системных и пользовательских приложений;
  • BASIS/Основное – оконная среда Xfce, Firefox, базовые утилиты и пакетный менеджер gslapt;
  • CORE/Минимальная – небольшой ассортимент консольных утилит, подходит для создания серверов;

Оформление Salix Xfce 14.2 мало отличается от оформления использовавшегося в Salix Xfce 14.1 (изменения коснулись оформления LILO, GDM и частично XFCE).

После авторизации запускается полноценное рабочее окружение Xfce с набором стандартных приложений. Разработчики Salix придерживается принципа разумного минимализма: «Одно приложение для одной задачи».

Состав пользовательских приложений в Salix Xfce 14.2 оставлен прежним (как и в Salix Xfce 14.1), большинство обновлено до текущих стабильных версий. Набор системных приложений дополнен графическим менеджером загрузки GUEFI (доступен только на 64-бит системах с использованием UEFI) и утилитой gtkreposetup (GTK аналог reposetup, инструмент для выбора зеркала репозитория).

Приложения входящие в Salix Xfce 14.2:

Для дальнейшего наращивания системы и обновления приложений в Salix Xfce 14.2 входит простой в использовании консольный менеджер пакетов, с поддержкой автоматической установки зависимостей spi (оболочка для slapt-get и slapt-src), он рекомендуется авторами проекта для поиска и установки пакетов, SlackBuilds и обновления системы.

При желании можно использовать Gslapt и Sourcery, имеется обслуживающая утилита salix-update-notifier, для периодической проверки на наличие обновлений и информировании о них пользователя через системный трей.

Традиционно имеется утилита «Установка мультимедийных кодеков / Install multimedia codecs», запускающая скрипт (сценарий) для автоматической установки комплекта кодеков, имеется консольная и GTK графическая версия скрипта.

Salix Xfce 14.2 полностью совместим с текущей версией Slackware Linux и может использовать её репозитории. Одним из улучшений релиза является создание нового репозитория "extra" и включения его "по умолчанию", в него добавляются пакеты собранные из SlackBuild скриптов. Работа над ним постоянно продолжается и репозиторий будет активно заполнятся пакетами.

Дополнительные пакеты можно найти в хранилищах независимых разработчиков и других модификаций Slackware, но использовать их надо осторожно, так как они могут быть частично несовместимыми (особенно свежие версии пакетов).

МИНИМАЛЬНЫЕ системные требования:

  • Процессор Pentium III или аналогичный;
  • Оперативная память 512 Мб;
  • 1,5Гб HDD (BASIS/Основное) 2,5Гб HDD (FULL/Полная);

(Минимальные требования, это не значит что они обязательные и единственно возможные! Это значит что такова минимальная конфигурация оборудования для более, менее комфортной работы в системе)

Домашняя страница

Русский раздел форума

Страница Salix OS на SourceForge.net

Комментариев: 7 RSS

Владельцам ноутбуков HP Compaq nx6110 обратить внимание на баг ядра 4.4.19:

После загрузки системы с этим ядром беспроводной интерфейс в hard blocked и аппаратной кнопкой разблокировки не разблокируется.

Беспроводной интерфейс не блокируется на ядрах 4.4.16 и ниже.

От Линукс-проекта не зависит, зависит от версии ядра.

Возврат функциональности кнопки аппаратной блокировки беспроводных интерфейсов ноутбука HP Compaq nx6110:

Clear CMOS на 15 минут согласно инструкции производителя ноутбука

Или:

F10 > BIOS Setup > File > Restore defaults

Save changes and exit

Кнопка снова начнёт работать.

В репозитории Slackware-14.2 неразломанное ядро 4.4.14.

Проверено и подтверждается:

Разлом беспроводной сети для ноутбука HP Compaq nx6110 начиная с ядра 4.4.19 и выше.

Ядра по 4.4.18 включительно, работающие и без разлома беспроводной сети.

Владельцам ноутбуков HP Compaq nx6110 обратить внимание на баг ядра 4.4.19:
Помню такой, он же бедолага времён хрюши выпуска, ещё до сп1 кажется?

Вы и вправду думаете что современные ядра должны с этим динозавром без проблем и левых манипуляций работать?

Вы и вправду думаете что современные ядра должны с этим динозавром без проблем и левых манипуляций работать?

.

Не думаю,- работают:

$ uname -r

4.4.18

.

Левая манипуляция на nx6110 с ядрами 4.4.18 и ниже, это параметр ядру:

reboot=bios

см. ядерную документацию:

https://www.kernel.org/doc/Documentation/kernel-parameters.txt

Можно ещё убрать синхронизацию (см. документацию)

.

Там парни в немного другом проекте подсказывали, что возможно разлом начался из-за коммита от каноникл.

А разлом пошёл начиная с ядра 4.4.19 в которое попал этот коммит. Ядрам 4.4.18 и ниже, вообще ничего не мешает нормально работать на этом железе.

.

Вы удивитесь, но эта железка используется как медиастанция.

При особых хитростях она вытянет два-три видеопотока сразу. sysstat соврать не даст.

Но для игр класса выше Q3 это железо совсем не пригодно. Это чистый бюджетный бизнес-класс того времени для процессоров с speedstep и sse2. Единственно чего ему не хватает, это сменного бокса с ssd-винчестером. lxde/xfce/tde для этого ноутбука рекомендуется.

salix-xfce/slackel-openbox наиболее подходящий вариант для этого железа.

Вы и вправду думаете что современные ядра должны с этим динозавром без проблем и левых манипуляций работать?

.

А вы действительно уверены что кодеры никогда не делают ошибок?

Владельцам ноутбуков HP Compaq nx6110 обратить внимание на баг ядра 4.4.19:

Помню такой, он же бедолага времён хрюши выпуска, ещё до сп1 кажется?

:-) Ноутбук nx6110 не мог появиться до выхода sp1. Он появился чуть больше чем через год после выхода пакета обновлений sp2 для ХРюшки.

Последний выпущенный для этого ноутбука процессор, это Pentium M 780 (2.26GHz)

В недавно отрелизившемся salixlive[64]-xfce-14.2-beta2.iso отсутствует пакет rfkill. Это может быть критично если в наличии только беспроводная сеть, а интерфейс в blocked.

Speccyfighter7 2017-05-22 в 16:46:10

Ресурс

http://salix.hostingxtreme.com/

дефолтно прописанный как источник получения пакетов, больше им не является. При попытке обновить список пакетов будет ошибка:

https://forum.salixos.org/viewtopic.php?p=42210&sid=4ab4af9f5e29c372732ca444c0ff9dea

Рекомендуется попинговать ресурсы и выбрать наиболее быстрое зеркало:

# cat /usr/share/salixtools/reposetup/repomirrors

http://mirror.inode.at/salix AT

http://ftp.belnet.be/salixos.org BE

http://mirror.its.dal.ca/salix CA

http://slackware.uk/salix EN

http://www.mirrorservice.org/sites/download.salixos.org EN

http://download.salixos.org FR

http://salix.enialis.net FR

http://ftp.cc.uoc.gr/mirrors/linux/salix GR

http://ftp.heanet.ie/pub/salix IE

http://salix.mirror.garr.it/mirrors/salix IT

http://ftp.nluug.nl/os/Linux/distr/salix NL

http://mirror.chmuri.net/salix PL

http://ftp.yzu.edu.tw/Linux/salix TW

http://mirrors.nix.org.ua/linux/salixos UA

http://mirrors.xmission.com/salix US

http://www.gtlib.gatech.edu/pub/salixos US

через

$ sudo reposetup

или

$ sudo su -

# reposetup

Дальше всё как всегда.

Ошибка поймалась на сборке salix версии 14.2.1:

Неверно указан дефолтный источник пакетов.

См. также:

hostingxtreme repository mirror to go down

https://forum.salixos.org/viewtopic.php?f=17&t=7254

http://salixos.org/mirmon.html

Оставьте комментарий!
Используйте нормальные имена.Войти через loginza
Если вы уже зарегистрированы как комментатор или хотите зарегистрироваться, укажите пароль и свой действующий email.
(При регистрации на указанный адрес придет письмо с кодом активации и ссылкой на ваш персональный аккаунт, где вы сможете изменить свои данные, включая адрес сайта, ник, описание, контакты и т.д.)



 
(обязательно)