Linux -- это интересно

Flow (VKontakte Audio Player)


Рубрика: Интернет ПО -> Аудио и видео ПО
Метки: | | | |
Просмотров: 1850

Плеер для прослушивания потокового аудио с социальной сети ВКонтакте.


Flow — автономное VK API / Qt (Qt5WebEngineWidgets) графическое приложения для прослушивания потокового аудио с социальной сети ВКонтакте (VKontakte Audio Player).

Для использования Flow необходимо иметь учётную запись "ВКонтакте" и авторизоваться в плеере (при закрытии плеера авторизация сохраняется).

Flow имеет простой и интуитивно понятный пользовательский интерфейс, доступны все "стандартные" функции для управления воспроизведением потокового аудио. Плеер может отображать музыкальную коллекцию, список популярных композиций или список рекомендаций, есть возможность поиска трека по названию или исполнителю.

Лицензия: GNU General Public License

Домашняя страница

Страница на opendesktop.org

Комментариев: 15 RSS
Константин1 2015-03-15 в 11:20:48

Ну хоть что то кроме vksaver сделали интересное. Нужно пробовать!

А как установить??

Не знаю что имеется у вас, я сделал просто:

src2pkg -CWD flow-master.zip
installpkg *

Скриншоты рулят, надо еще чего-нибудь про скрепы))

А как установить??

Читай документацию, вконтактная мелюзга! ;)

Над глянуть. Жаль pulsar не обновляется и с новым gstreaner-ом не хочет собираться.

Я так понял, сабж не умеет подключать паблики, искать альбом и делать плейлисты?

Читай документацию, вконтактная мелюзга! ;)

А сам такой взрослый и умный,что кроме как отправить читать ни чего не можешь?

Ну так если не хотите говорить что имеете, то тогда распакуйте архив flow-master.zip, потом в каталоге qmake & make и просто пользуйте его бинарнком, как портабле и всех делов!

Жаль pulsar не обновляется и с новым gstreaner-ом не хочет собираться.
На Арчике без проблем и особых телодвижений собрался, сегодня сверстаю темку и покажу.

Разработчик Flow7 2015-03-16 в 23:42:48

Господа, не ругайтесь!

На домашней странице программы есть инструкция по установке, она же есть в установочном архиве, скачать который можно там же. На текущий момент доступна установка только для х64.

К приложению изначально предъявлялись требования исключительно прослушивания аудиофайлов, никакой функциональности работы с пользовательской библиотекой не предполагается.

По поводу альбомов и пабликов - хороший feature request, рассматриваю. Текущие задачи - это установка для х32 Linux-систем и возможность портирования на Windows.

>>На Арчике без проблем и особых телодвижений собрался, сегодня сверстаю темку и покажу.

Я глянул pkgbuild, там gstreamer0.10

Пробегайлоф9 2015-03-17 в 15:00:11

> Текущие задачи - это установка для х32 Linux-систем

> и возможность портирования на Windows

На Арчике 32 нормально работает, а на винду зря, не тратьте время! Скольких вин-пользователей я знаю, почти для всех из их если софина не крякнута или не брендовая, то они уверены что она фуфло! Как не печально, но переубедитьне получается. Если программу не продают, а отдают просто так, значит она ... Вот так! ))

А возможность свернуть в трей будет?

Сергей10 2015-03-17 в 16:00:21

На Лубунте 14.04-32 требует libQt5WebEngineWidgets.so.5

а где его взять, как то не могу найти, подскажет кто?

Разработчик Flow11 2015-03-17 в 23:36:57
На Лубунте 14.04-32 требует libQt5WebEngineWidgets.so.5
а где его взять, как то не могу найти, подскажет кто?

Поддержка для 32-разрядных систем еще не обеспечена.

А возможность свернуть в трей будет?

Я подумаю.

На Лубунте 14.04-32 требует libQt5WebEngineWidgets.so.5
Поддержка для 32-разрядных систем еще не обеспечена.

Это в *убунтах пакета qt5-webengine нет, в Arch и .rpm дистрах (OpenMandriva, openSUSE, ROSA) он давно имеется, можете конвертнуть если хочется, или на Qt-Project имеются инструкции.

Разработчик Flow13 2015-03-18 в 01:03:33
Это в *убунтах пакета qt5-webengine нет, в Arch и .rpm дистрах (OpenMandriva, openSUSE, ROSA) он давно имеется, можете конвертнуть если хочется, или на Qt-Project имеются инструкции.

Соль в том, что Вам не нужно даже иметь установленные библиотеки Qt5, поскольку в установочнике они поставляются вместе с исполняемым файлом. Это актуально для систем, не имеющих в репозиториях пакетов с Qt5.

Разработчик Flow14 2015-03-27 в 00:10:26

Приложение получило обновление.

Основные изменения:

* Новый дизайн - еще красивее и удобнее

* Добавлены базовые возможности управления плеером через трей

Разработчик Flow15 2015-03-28 в 02:46:26

Снова обновление!

В этот раз добавил отображение обложки, если она имеется у аудиозаписи.

Появилась первая зависимость, TagLib, устанавливается очень просто, инструкцию можно найти в разделе Build Requirements.

Оставьте комментарий!
Используйте нормальные имена.Войти через loginza
Если вы уже зарегистрированы как комментатор или хотите зарегистрироваться, укажите пароль и свой действующий email.
(При регистрации на указанный адрес придет письмо с кодом активации и ссылкой на ваш персональный аккаунт, где вы сможете изменить свои данные, включая адрес сайта, ник, описание, контакты и т.д.)



 
(обязательно)